ĆU HÌNH MPLS LDP

View previous topic View next topic Go down

ĆU HÌNH MPLS LDP

Post  chantroitinhoc on Thu Oct 06, 2011 9:51 pm

Bài LAB này ti giới thịu cách ću hình MPLS LDP.
Topology:



1. Các bạn tự ću hình cơ bản trn các router, thít ḷp địa chỉ IP như trong m hình.

2. Ću hình định tuýn OSPF trn các router và cho quảng bá t́t cả các lớp mạng.

3. Ću hình kích hoạt tính năng MPLS với giao thức MPLS chủn IETF trn các router P2, P3 và P4:


P2(config)# interface f0/0
P2(config-if)# mpls ip
P2(config)# interface f1/0
P2(config-if)# mpls ip

P3(config)# interface f0/0
P3(config-if)# mpls ip
P3(config)# interface f1/0
P3(config-if)# mpls ip

P4(config)# interface f0/0
P4(config-if)# mpls ip
P4(config)# interface f1/0
P4(config-if)# mpls ip


4. Ću hình router P1 đ̉ kích hoạt cùng giao thức MPLS mà khng sử dụng ḷnh mpls ip:

P1(config)# interface f0/0
P1(config-if)# tag-switching ip

P1(config)# interface f1/0
P1(config-if)# tag-switching ip

Các bạn có th̉ kỉm tra lại ću hình các interface f0/0, f1/0 trn P1 đ̉ th́y giao thức mpls đã được kích hoạt.

P1# show running-config interface f0/0
P1# show running-config interface f1/0


5. Ću hình trn các router chỉ cho sử dụng dãy nhãn từ 20 đ́n 200:


P1(config)# mpls label range 20 200

Các bạn ću hình tương tự trn các router P2, P3 và P4.


6. Ću hình router P1 sử dụng địa chỉ IP c̉ng f0/0 làm MPLS Router-ID:

Chúng ta dùng ḷnh show mpls ldp neighbor trn router P2 đ̉ th̀y ID của router P1 chính là 1.1.1.1:0

P2# show mpls ldp neighbor

Chúng ta thay đ̉i ID trn router P1 như sau:

P1(config)# mpls ldp router-id fastEthernet 0/0 force

By giờ chúng ta qua router P2 thì th́y router-id của neighbor P1 đã thay đ̉i là 192.168.12.1:0


7. Ću hình trn các router đ̉ gửi MPLS Hello sau m̃i 2 gíy và holdtime là 10 gịy:

P1(config)# mpls ldp discovery hello interval 2
P1(config)# mpls ldp discovery hello holdtime 10

Chúng ta có th̉ dùng ḷnh show running-config | include discovery đ̉ kỉm tra thng tin vừa ću hình

P1# show running-config | include discovery

Các bạn ću hình tương tự trn các router P2, P3 và P4.


8. Ću hình router P3 và P4 đ̉ thít ḷp ḱt ńi LDP giữa các interface của chúng:

P3(config)# interface f1/0
P3(config-if)# mpls ldp discovery transport-address interface

P4(config)# interface f1/0
P4(config-if)# mpls ldp discovery transport-address interface

Các bạn có th̉ kỉm tra lại bằng ḷnh show mpls ldp neighbor

P3# show mpls ldp neighbor

P4# show mpls ldp neighbor


9. Ću hình trn t́t cả các router đ̉ sử dụng cơ ch́ chứng thực MPLS MD5 với password là ispace:

P1(config)# mpls ldp neighbor 2.2.2.2 password ispace
P1(config)# mpls ldp neighbor 3.3.3.3 password ispace

P2(config)# mpls ldp neighbor 192.168.12.1 password ispace
P2(config)# mpls ldp neighbor 4.4.4.4 password ispace

P3(config)# mpls ldp neighbor 192.168.12.1 password ispace
P3(config)# mpls ldp neighbor 4.4.4.4 password ispace

P4(config)# mpls ldp neighbor 2.2.2.2 password ispace
P4(config)# mpls ldp neighbor 3.3.3.3 password ispace


10. Ću hình đ̉ trường TTL từ các gói tin IP được sao chép ln nhãn trn các router:

P1(config)# mpls ip propagate-ttl

Các bạn ću hình tương tự trn các router P2, P3 và P4.


11. Ću hình quảng bá default route trn router P2:

P2(config)# router ospf 1
P2(config-router)# default-information originate always

By giờ các bạn có th̉ kỉm tra thng tin trn router P1:

P1# show ip route
P1# show mpls forwarding-table

Sau khi kỉm tra bảng MPLS forward thì khng th́y chuỷn típ cho default route.
Do ṿy chúng ta c̀n ću hình MPLS ip default route trn các router P1, P3 và P4:

P1(config)# mpls ip default-route

Tương tự bạn ću hình trn router P3, P4. Sau đó các bạn kỉm tra lại bảng forward thì th́y đã có sự thay đ̉i.


12. Ću hình maximum hop count cho LDP là 10 trn các router:

P1(config)# mpls ldp maxhops 10

Các bạn ću hình tương tự trn P2, P3 và P4.




chantroitinhoc
Admin

Posts : 149
Join date : 2008-01-16

View user profile http://chantroitinhoc.niceboard.net

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum